Discussion:
[Berlin-wireless] Freifunk auf unserem Dach
wg1337
2014-04-26 12:01:20 UTC
Permalink
Hallo,

wir wohnen in der 6. Etage. Die Idee ist, dass wir unseren Vermieter
fragen, ob er damit einverstanden wäre, wenn wir eine Freifunkanlage auf
dem Dach betreiben würden, die könnte dann vielleicht sogar 360°
verteilen. Wir haben z.B. eine super Sichtverbindung zum Neuköllner
Rathaus, sogar schon vom Balkon aus.

Hier ein paar Fotos:
Balkon hinterer Hof Norden:
Loading Image...
Balkon hinterer Hof Westen:
Loading Image...
Balkon vorderer Hof Norden:
Loading Image...
Balkon vorderer Hof Osten:
Loading Image...


Macht das aus eurer Sicht Sinn?
Wenn ja, wie geht man am Besten vor beim Erstkontakt? Gibt es sowas wie
ein Musteranschreiben?

Was wir auf jeden Fall machen wollen ist die Verbindung zum Rathaus. Wir
haben hier 2 VDSL-Anschlüsse, die wir mit einbinden möchten. Wenn uns
dabei jemand mit der optimalen Konfigration helfen könnte wäre das auch
super.

Schöne Grüße
maria
Philipp Borgers
2014-04-26 12:38:19 UTC
Permalink
Natürlich macht das Sinn. Wie genau eine Aufbau aussieht muss man dann
sehen. Bei der Konfiguration helfen wir euch gerne!

Soweit ich weiß haben wir keine Erfahrung mit Vermieter_innen und auch
keine Musteranschreiben. Anbei nur ein Schreiben, dass wir in Neukölln
an Kirchen oder Hausprojekte verschickt haben:

http://pad.spline.de/ff-nk-schreiben-projekte
http://pad.spline.de/ff-nk-schreiben-kirchen

Ich würde noch darauf eingehen welchen Mehrwert eine Installation für
das Haus und die Hausbewohnerinnen haben kann. Sinnvoll ist sicher auch
ein Abschnitt zu den Kosten (einmalig und laufende) und wer die
übernehmen soll. Vielleicht will man auch auf die Installationen auf
Rathäusern und Kirchen hinweisen und feststellen, dass das Haus nicht
das erste mit Freifunkanlage ist.

Wir lesen euren Text auch gerne vorher mal, wenn euch das hilft.

Mit privaten Vermietern kann man vielleicht auch mal einfach so auf dem
Flur ein erstes Gespräch führen.

LG Philipp
Post by wg1337
Hallo,
wir wohnen in der 6. Etage. Die Idee ist, dass wir unseren Vermieter
fragen, ob er damit einverstanden wäre, wenn wir eine Freifunkanlage auf
dem Dach betreiben würden, die könnte dann vielleicht sogar 360°
verteilen. Wir haben z.B. eine super Sichtverbindung zum Neuköllner
Rathaus, sogar schon vom Balkon aus.
https://www.dropbox.com/s/2irtaaeh82pkyqe/IMG_20140426_131103.jpg
https://www.dropbox.com/s/xf8nlfpikpr51wn/IMG_20140426_131117.jpg
https://www.dropbox.com/s/b1i0dkl5ff2giah/IMG_20140426_131208.jpg
https://www.dropbox.com/s/m3pho2pc2bxjnw2/IMG_20140426_131213.jpg
Macht das aus eurer Sicht Sinn?
Wenn ja, wie geht man am Besten vor beim Erstkontakt? Gibt es sowas wie
ein Musteranschreiben?
Was wir auf jeden Fall machen wollen ist die Verbindung zum Rathaus. Wir
haben hier 2 VDSL-Anschlüsse, die wir mit einbinden möchten. Wenn uns
dabei jemand mit der optimalen Konfigration helfen könnte wäre das auch
super.
Schöne Grüße
maria
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname : signature.asc
Dateityp : application/pgp-signature
Dateigröße : 901 bytes
Beschreibung: OpenPGP digital signature
URL : <http://lists.berlin.freifunk.net/cgi-bin/mailman/private/berlin/attachments/20140426/835dc706/attachment.pgp>
wg1337
2014-04-26 14:05:26 UTC
Permalink
Wir haben keinen privaten Vermieter, sondern würden der Hausverwaltung
schreiben.

In den Briefen steht was von 10 EUR pro Gerät pro Jahr, das könnte
unsere WG übernehmen, aber ich weiß noch nicht, was man für die
einmaligen Kosten veranschlagen sollte. Ich hab auf verschiedenen Seiten
was von Strom legen, Blitzableitern und zertifizierten Abnahmen von
Elektrotechnik-Installationen durch Fachhandwerker gelesen und natürlich
die Geräte selbst, stimmt das oder fehlt was? Was ist der Preis für das
Komplettpaket?

Schöne Grüße
maria
Post by Philipp Borgers
Natürlich macht das Sinn. Wie genau eine Aufbau aussieht muss man dann
sehen. Bei der Konfiguration helfen wir euch gerne!
Soweit ich weiß haben wir keine Erfahrung mit Vermieter_innen und auch
keine Musteranschreiben. Anbei nur ein Schreiben, dass wir in Neukölln
http://pad.spline.de/ff-nk-schreiben-projekte
http://pad.spline.de/ff-nk-schreiben-kirchen
Ich würde noch darauf eingehen welchen Mehrwert eine Installation für
das Haus und die Hausbewohnerinnen haben kann. Sinnvoll ist sicher auch
ein Abschnitt zu den Kosten (einmalig und laufende) und wer die
übernehmen soll. Vielleicht will man auch auf die Installationen auf
Rathäusern und Kirchen hinweisen und feststellen, dass das Haus nicht
das erste mit Freifunkanlage ist.
Wir lesen euren Text auch gerne vorher mal, wenn euch das hilft.
Mit privaten Vermietern kann man vielleicht auch mal einfach so auf dem
Flur ein erstes Gespräch führen.
LG Philipp
Post by wg1337
Hallo,
wir wohnen in der 6. Etage. Die Idee ist, dass wir unseren Vermieter
fragen, ob er damit einverstanden wäre, wenn wir eine Freifunkanlage auf
dem Dach betreiben würden, die könnte dann vielleicht sogar 360°
verteilen. Wir haben z.B. eine super Sichtverbindung zum Neuköllner
Rathaus, sogar schon vom Balkon aus.
https://www.dropbox.com/s/2irtaaeh82pkyqe/IMG_20140426_131103.jpg
https://www.dropbox.com/s/xf8nlfpikpr51wn/IMG_20140426_131117.jpg
https://www.dropbox.com/s/b1i0dkl5ff2giah/IMG_20140426_131208.jpg
https://www.dropbox.com/s/m3pho2pc2bxjnw2/IMG_20140426_131213.jpg
Macht das aus eurer Sicht Sinn?
Wenn ja, wie geht man am Besten vor beim Erstkontakt? Gibt es sowas wie
ein Musteranschreiben?
Was wir auf jeden Fall machen wollen ist die Verbindung zum Rathaus. Wir
haben hier 2 VDSL-Anschlüsse, die wir mit einbinden möchten. Wenn uns
dabei jemand mit der optimalen Konfigration helfen könnte wäre das auch
super.
Schöne Grüße
maria
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
-------------- nächster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.berlin.freifunk.net/cgi-bin/mailman/private/berlin/attachments/20140426/47445e43/attachment.html>
Sven-Ola Tuecke
2014-04-27 07:58:01 UTC
Permalink
Hallo Maria,

Komplettpakete sind typicherweise unsinnig teuer. Bei *der* Sicht
(https://www.dropbox.com/s/2irtaaeh82pkyqe/IMG_20140426_131103.jpg)
müsste es ausreichen, eine M5-Loco mit 50m Klingeldraht dranzuhängen.
Kosten: 50,-- für die Loco
(http://www.idealo.de/preisvergleich/Liste/13720440/nanostation-m5.html), 20
für den Klingeldraht. Bessere Variante: Cat5-Leitung vom Dach bis zu
euren Wohnräumen, diese Leitung ist aber dicker. Und 10,-- für eine
Möbelstütze / Besentiel / Antennenträgerdings, die an einen Schornstein
geschraubt wird. Wegen der Blitze: immer schön schauen, dass die Antenne
nicht der höchste (metallische) Dachpunkt ist bzw. möglichst 45°
unterhalb von anderen in den vorhandenen Blitzschutz integrierten Dingen
(z.B. so Fangstangen) aber niemals direkt an die Blitzableiter
dranschließen. Im Anschreiben sollte drinstehen, dass 12-18V
Kleinspannung (also keine 220V Netzspannung) und auch keine SAT-Schüssel
da hoch sollen (Netzspannung und SAT-Schüsseln machen bei Vermietern
rote Lampen an).

Ahja. Was Philipp nicht erwähnte. Auf dem Rathaus Neukölln sind fast nur
5 Ghz-Geräte verbaut. Es gibt nur ein 2.4er, das guckt auf dem
Rathaus-Vorplatz. Wegen Dachkante aber nicht direkt am Eingang sondern
mit Laptop/Mobiltelefon erst ab ~~ der Mitte des Platzes nutzbar.

Gruß // Sven-Ola
Post by wg1337
Wir haben keinen privaten Vermieter, sondern würden der Hausverwaltung
schreiben.
In den Briefen steht was von 10 EUR pro Gerät pro Jahr, das könnte
unsere WG übernehmen, aber ich weiß noch nicht, was man für die
einmaligen Kosten veranschlagen sollte. Ich hab auf verschiedenen
Seiten was von Strom legen, Blitzableitern und zertifizierten Abnahmen
von Elektrotechnik-Installationen durch Fachhandwerker gelesen und
natürlich die Geräte selbst, stimmt das oder fehlt was? Was ist der
Preis für das Komplettpaket?
Schöne Grüße
maria
-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname : signature.asc
Dateityp : application/pgp-signature
Dateigröße : 263 bytes
Beschreibung: OpenPGP digital signature
URL : <http://lists.berlin.freifunk.net/cgi-bin/mailman/private/berlin/attachments/20140427/3fc458a7/attachment.pgp>
wg1337
2014-04-27 10:40:55 UTC
Permalink
Vielen Dank für die Anworten. Hier ist der Text den wir schicken würden:
http://pad.spline.de/K5IAQVNYFT

Über Anmerkungen würen wir uns freuen!

Schöne Grüße
maria
Post by Sven-Ola Tuecke
Hallo Maria,
Komplettpakete sind typicherweise unsinnig teuer. Bei *der* Sicht
(https://www.dropbox.com/s/2irtaaeh82pkyqe/IMG_20140426_131103.jpg)
müsste es ausreichen, eine M5-Loco mit 50m Klingeldraht dranzuhängen.
Kosten: 50,-- für die Loco
(http://www.idealo.de/preisvergleich/Liste/13720440/nanostation-m5.html), 20
für den Klingeldraht. Bessere Variante: Cat5-Leitung vom Dach bis zu
euren Wohnräumen, diese Leitung ist aber dicker. Und 10,-- für eine
Möbelstütze / Besentiel / Antennenträgerdings, die an einen Schornstein
geschraubt wird. Wegen der Blitze: immer schön schauen, dass die Antenne
nicht der höchste (metallische) Dachpunkt ist bzw. möglichst 45°
unterhalb von anderen in den vorhandenen Blitzschutz integrierten Dingen
(z.B. so Fangstangen) aber niemals direkt an die Blitzableiter
dranschließen. Im Anschreiben sollte drinstehen, dass 12-18V
Kleinspannung (also keine 220V Netzspannung) und auch keine SAT-Schüssel
da hoch sollen (Netzspannung und SAT-Schüsseln machen bei Vermietern
rote Lampen an).
Ahja. Was Philipp nicht erwähnte. Auf dem Rathaus Neukölln sind fast nur
5 Ghz-Geräte verbaut. Es gibt nur ein 2.4er, das guckt auf dem
Rathaus-Vorplatz. Wegen Dachkante aber nicht direkt am Eingang sondern
mit Laptop/Mobiltelefon erst ab ~~ der Mitte des Platzes nutzbar.
Gruß // Sven-Ola
Post by wg1337
Wir haben keinen privaten Vermieter, sondern würden der Hausverwaltung
schreiben.
In den Briefen steht was von 10 EUR pro Gerät pro Jahr, das könnte
unsere WG übernehmen, aber ich weiß noch nicht, was man für die
einmaligen Kosten veranschlagen sollte. Ich hab auf verschiedenen
Seiten was von Strom legen, Blitzableitern und zertifizierten Abnahmen
von Elektrotechnik-Installationen durch Fachhandwerker gelesen und
natürlich die Geräte selbst, stimmt das oder fehlt was? Was ist der
Preis für das Komplettpaket?
Schöne Grüße
maria
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
-------------- nächster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.berlin.freifunk.net/cgi-bin/mailman/private/berlin/attachments/20140427/478122fe/attachment.html>
wg1337
2014-04-29 17:49:42 UTC
Permalink
So, die Mail an die Hausverwaltung ist raus, mal sehen was sie sagen.
Ich hab die Briefe wie versprochen im Wiki verlinkt. Da ich keine
passende Seite gefunden habe, hab ich hier
http://wiki.freifunk.net/Beispielanschreiben eine neue in der Kategory
FAQ angelegt. Keine Ahnung wo man das noch verlinken könnte.

Uuuund: Heute ist unsere kleine süße NanoStation loco M5 angekommen, mit
der wir vom Balkon aus schonmal testen könnten \o/
Im Wiki steht ja, dass da kein OpenWrt drauf geht und ich habe nur die
Screenshots auf dieser Seite
http://wiki.freifunk.net/Berlin:Standorte:Bezirksamt_Kreuzberg gefunden.
Gibt es noch irgendwo eine Anleitung, die ich übersehen habe? Wenn nicht
könnten wir versuchen uns an den Screenshots langzuhangeln. Gibt es
dabei was zu beachten bzw. was sollte man unbedingt vorher gelesen haben?

Schöne Grüße
maria
Post by wg1337
Vielen Dank für die Anworten. Hier ist der Text den wir schicken
würden: http://pad.spline.de/K5IAQVNYFT
Über Anmerkungen würen wir uns freuen!
Schöne Grüße
maria
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
Philipp Borgers
2014-04-30 13:39:53 UTC
Permalink
Post by wg1337
So, die Mail an die Hausverwaltung ist raus, mal sehen was sie sagen.
Ich hab die Briefe wie versprochen im Wiki verlinkt. Da ich keine
passende Seite gefunden habe, hab ich hier
http://wiki.freifunk.net/Beispielanschreiben eine neue in der Kategory
FAQ angelegt. Keine Ahnung wo man das noch verlinken könnte.
Sieht doch ganz gut aus. Danke!
Post by wg1337
Uuuund: Heute ist unsere kleine süße NanoStation loco M5 angekommen, mit
der wir vom Balkon aus schonmal testen könnten \o/
Im Wiki steht ja, dass da kein OpenWrt drauf geht und ich habe nur die
Screenshots auf dieser Seite
http://wiki.freifunk.net/Berlin:Standorte:Bezirksamt_Kreuzberg gefunden.
Gibt es noch irgendwo eine Anleitung, die ich übersehen habe? Wenn nicht
könnten wir versuchen uns an den Screenshots langzuhangeln. Gibt es
dabei was zu beachten bzw. was sollte man unbedingt vorher gelesen haben?
Ihr könnt die Nanostation erst mal mit der originalen Firmware testen.
Dazu einfach auf dem Router einloggen und im Wireless-Bereich nach der
SCAN-Funktion suchen und Router Richtung Rathaus halten.

Wenn ihr guten Empfang habt, könnt ihr den Router entweder weiter mit
der Original-Firmware und einem zweiten OpenWrt-Router betreiben oder
OpenWrT auf der Nanostation installieren.

In beiden Fällen müsst ihr den Router als Client/Station mit einem
Master auf dem Rathaus verbinden. Einfach den Master wählen, der den
besten Empfang verspricht. Sicherstellen, dass der Client auch Daten
senden und empfangen kann. Kann er das nicht, ist meistens die
WDS-Einstellung Schuld.

Wenn ihr den Router mit der originalen Firmware nutzt, den Bridge-Mode
einschalten und WDS ausschalten (ist das richtig?). Der Bridge-Mode
leitet die Daten vom WLAN über das LAN zu einem zweiten Router. Auf dem
zweiten Router muss dann OLSR auf dem Netzwerk-Port konfiguriert sein.
Der zweite Router übernimmt dann das eigentliche Routing.

Wenn ihr OpenWrt nutzt, dann könnt ihr die Nanostation ganz normal mit
dem Freifunk-Assistenten einrichten. Danach müsst ihr das WLAN im
Terminal bzw. in der Konfiguration als Station/Client konfigurieren
(Mode [1]) und den richtigen Channel und SSID wählen.

[1] http://wiki.openwrt.org/doc/uci/wireless

Könnt ihr damit was anfangen?

Viel Erfolg!

LG Philipp
Post by wg1337
Schöne Grüße
maria
Post by wg1337
Vielen Dank für die Anworten. Hier ist der Text den wir schicken
würden: http://pad.spline.de/K5IAQVNYFT
Über Anmerkungen würen wir uns freuen!
Schöne Grüße
maria
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname : signature.asc
Dateityp : application/pgp-signature
Dateigröße : 901 bytes
Beschreibung: OpenPGP digital signature
URL : <http://lists.berlin.freifunk.net/cgi-bin/mailman/private/berlin/attachments/20140430/29740dd0/attachment.pgp>
wg1337
2014-05-02 10:21:10 UTC
Permalink
Danke für die Hinweise, ich denke wir haben gestern was hinbekommen. Wir
haben uns erstmal mit freifunk-bbb-rhnk-ssw verbunden
(freifunk-bbb-rhnk-oso würde auch gehen und btw wir sehen auch
freifunk-martin-luther-sw) Wir haben der Nanostation die IP 104.205.0.78
gegeben und mit unserem Freifunkrouter im Wohnzimmer verbunden (auf dem
haben wir einen der Switchports umkonfiguriert und noch ein Interface
für ein Netzwerk mit der Nanostation angelegt).
Wie testen wir jetzt am besten ob da auch was vom Rathaus ankommt und
wieder zurück geht und ob unser Internet richtig benutzt wird? Die
Graphen auf der Nanostation und auf dem Freifunkrouter gehen schon
lustig hoch und runter. Nur eine Sache kommt uns komisch vor:
Wenn ich mit meinem Laptop in unserem Freifunk bin und ein traceroute
mache, gehen die Packete über

traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 104.205.0.49 (104.205.0.49) 2.566 ms 3.245 ms 5.125 ms
2 172.31.240.1 (172.31.240.1) 22.555 ms 24.734 ms 26.192 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 27.001 ms 27.854 ms 28.656 ms
4 vlan935.sepia.in-berlin.de (217.197.91.131) 29.441 ms 30.241 ms
31.141 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 32.333 ms 34.094 ms
35.119 ms
6 google.ber.ecix.net (194.9.117.34) 36.070 ms 24.303 ms 21.882 ms
7 209.85.249.184 (209.85.249.184) 24.071 ms 24.875 ms 29.587 ms
8 66.249.95.143 (66.249.95.143) 29.594 ms 66.249.95.175
(66.249.95.175) 32.655 ms 64.233.175.187 (64.233.175.187) 32.617 ms
9 216.239.48.53 (216.239.48.53) 32.622 ms 64.233.174.55
(64.233.174.55) 33.445 ms 216.239.48.53 (216.239.48.53) 32.596 ms
10 * * *
11 google-public-dns-a.google.com (8.8.8.8) 21.893 ms 22.736 ms 23.642 ms

ein traceroute auf der nanostation sieht so aus:
1 104.205.0.77 0.505 ms · 0.379 ms · 0.322 ms
2 217.0.119... 16.007 ms · 48.543 ms · 15.955 ms
3 217.0.76... 54.295 ms · 18.113 ms · 57.684 ms
4 62.154.47.69 155.259 ms · 16.187 ms · 60.107 ms
5 194.25.211.26 18.833 ms · 62.464 ms · 16.542 ms
6 209.85.249.182 36.444 ms · 72.146 ms · 16.399 ms
7 64.233.175.187 17.644 ms · 16.884 ms · 54.441 ms
8 64.233.174.53 17.277 ms · 93.991 ms · 17.091 ms
9 * · * · *
10 8.8.8.8 16.930 ms · 53.368 ms · 16.634 ms


Das sieht irgendwie falsch aus. Die Packete von der Nanostation müssen
doch auch durch das VPN, oder?

Schöne Grüße
maria
Post by Philipp Borgers
Post by wg1337
So, die Mail an die Hausverwaltung ist raus, mal sehen was sie sagen.
Ich hab die Briefe wie versprochen im Wiki verlinkt. Da ich keine
passende Seite gefunden habe, hab ich hier
http://wiki.freifunk.net/Beispielanschreiben eine neue in der Kategory
FAQ angelegt. Keine Ahnung wo man das noch verlinken könnte.
Sieht doch ganz gut aus. Danke!
Post by wg1337
Uuuund: Heute ist unsere kleine süße NanoStation loco M5 angekommen, mit
der wir vom Balkon aus schonmal testen könnten \o/
Im Wiki steht ja, dass da kein OpenWrt drauf geht und ich habe nur die
Screenshots auf dieser Seite
http://wiki.freifunk.net/Berlin:Standorte:Bezirksamt_Kreuzberg gefunden.
Gibt es noch irgendwo eine Anleitung, die ich übersehen habe? Wenn nicht
könnten wir versuchen uns an den Screenshots langzuhangeln. Gibt es
dabei was zu beachten bzw. was sollte man unbedingt vorher gelesen haben?
Ihr könnt die Nanostation erst mal mit der originalen Firmware testen.
Dazu einfach auf dem Router einloggen und im Wireless-Bereich nach der
SCAN-Funktion suchen und Router Richtung Rathaus halten.
Wenn ihr guten Empfang habt, könnt ihr den Router entweder weiter mit
der Original-Firmware und einem zweiten OpenWrt-Router betreiben oder
OpenWrT auf der Nanostation installieren.
In beiden Fällen müsst ihr den Router als Client/Station mit einem
Master auf dem Rathaus verbinden. Einfach den Master wählen, der den
besten Empfang verspricht. Sicherstellen, dass der Client auch Daten
senden und empfangen kann. Kann er das nicht, ist meistens die
WDS-Einstellung Schuld.
Wenn ihr den Router mit der originalen Firmware nutzt, den Bridge-Mode
einschalten und WDS ausschalten (ist das richtig?). Der Bridge-Mode
leitet die Daten vom WLAN über das LAN zu einem zweiten Router. Auf dem
zweiten Router muss dann OLSR auf dem Netzwerk-Port konfiguriert sein.
Der zweite Router übernimmt dann das eigentliche Routing.
Wenn ihr OpenWrt nutzt, dann könnt ihr die Nanostation ganz normal mit
dem Freifunk-Assistenten einrichten. Danach müsst ihr das WLAN im
Terminal bzw. in der Konfiguration als Station/Client konfigurieren
(Mode [1]) und den richtigen Channel und SSID wählen.
[1] http://wiki.openwrt.org/doc/uci/wireless
Könnt ihr damit was anfangen?
Viel Erfolg!
LG Philipp
Post by wg1337
Schöne Grüße
maria
Post by wg1337
Vielen Dank für die Anworten. Hier ist der Text den wir schicken
würden: http://pad.spline.de/K5IAQVNYFT
Über Anmerkungen würen wir uns freuen!
Schöne Grüße
maria
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
-------------- nächster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.berlin.freifunk.net/cgi-bin/mailman/private/berlin/attachments/20140502/6ca49439/attachment.html>
Philipp Borgers
2014-05-02 15:46:27 UTC
Permalink
Die IPs der Router auf dem Rathaus findet ihr im Wiki:

http://wiki.freifunk.net/Berlin:Standorte:Rathaus_Neukoelln#IPs

Wenn euer Setup erfolgreich mit dem Rathaus verbunden ist, solltet ihr
den Core-Router unter 104.206.3.1 erreichen. Wenn ihr gucken wollt, ob
ihr vom Rathaus weiter kommt, könnt ihr z.B. den Core-Router der
Martin-Luther-Kirche pingen: 104.206.1.14

Was habt ihr jetzt auf der Nanostation installiert? Freifunk-Firmware
oder Ubiquiti-Firmware? Ideal wäre, wenn ihr nochmal beschreibt, was ihr
wo konfiguriert habt. Konfiguration kopieren geht auch.

Die 104.205.0.77 ist die IP des Internet-Routers auf dem neuen Interface?

Auf dem Internet-Router müsst ihr sicherstellen, dass der Port an dem
die Nanostation hängt auch in der Firewall (/etc/config/firewall) in der
richtigen Zone (freifunk) ist. Man kann eine Liste von Interfaces
angeben. Das sollte verhindern, dass Daten einfach so ins Internet
geleitet werden.

Der Internet-Router muss auf dem Interface zur Nanostation OLSR sprechen
um mit dem ganzen Netz zu sprechen. Das könnt ihr in /etc/config/olsrd
einstellen.

Wir können das auch im Jabber versuchen zu debuggen:

booo at jabber.spline.de

LG Philipp
Post by wg1337
Danke für die Hinweise, ich denke wir haben gestern was hinbekommen. Wir
haben uns erstmal mit freifunk-bbb-rhnk-ssw verbunden
(freifunk-bbb-rhnk-oso würde auch gehen und btw wir sehen auch
freifunk-martin-luther-sw) Wir haben der Nanostation die IP 104.205.0.78
gegeben und mit unserem Freifunkrouter im Wohnzimmer verbunden (auf dem
haben wir einen der Switchports umkonfiguriert und noch ein Interface
für ein Netzwerk mit der Nanostation angelegt).
Wie testen wir jetzt am besten ob da auch was vom Rathaus ankommt und
wieder zurück geht und ob unser Internet richtig benutzt wird? Die
Graphen auf der Nanostation und auf dem Freifunkrouter gehen schon
Wenn ich mit meinem Laptop in unserem Freifunk bin und ein traceroute
mache, gehen die Packete über
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 104.205.0.49 (104.205.0.49) 2.566 ms 3.245 ms 5.125 ms
2 172.31.240.1 (172.31.240.1) 22.555 ms 24.734 ms 26.192 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 27.001 ms 27.854 ms 28.656 ms
4 vlan935.sepia.in-berlin.de (217.197.91.131) 29.441 ms 30.241 ms
31.141 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 32.333 ms 34.094 ms
35.119 ms
6 google.ber.ecix.net (194.9.117.34) 36.070 ms 24.303 ms 21.882 ms
7 209.85.249.184 (209.85.249.184) 24.071 ms 24.875 ms 29.587 ms
8 66.249.95.143 (66.249.95.143) 29.594 ms 66.249.95.175
(66.249.95.175) 32.655 ms 64.233.175.187 (64.233.175.187) 32.617 ms
9 216.239.48.53 (216.239.48.53) 32.622 ms 64.233.174.55
(64.233.174.55) 33.445 ms 216.239.48.53 (216.239.48.53) 32.596 ms
10 * * *
11 google-public-dns-a.google.com (8.8.8.8) 21.893 ms 22.736 ms 23.642 ms
1 104.205.0.77 0.505 ms · 0.379 ms · 0.322 ms
2 217.0.119... 16.007 ms · 48.543 ms · 15.955 ms
3 217.0.76... 54.295 ms · 18.113 ms · 57.684 ms
4 62.154.47.69 155.259 ms · 16.187 ms · 60.107 ms
5 194.25.211.26 18.833 ms · 62.464 ms · 16.542 ms
6 209.85.249.182 36.444 ms · 72.146 ms · 16.399 ms
7 64.233.175.187 17.644 ms · 16.884 ms · 54.441 ms
8 64.233.174.53 17.277 ms · 93.991 ms · 17.091 ms
9 * · * · *
10 8.8.8.8 16.930 ms · 53.368 ms · 16.634 ms
Das sieht irgendwie falsch aus. Die Packete von der Nanostation müssen
doch auch durch das VPN, oder?
Schöne Grüße
maria
Post by Philipp Borgers
Post by wg1337
So, die Mail an die Hausverwaltung ist raus, mal sehen was sie sagen.
Ich hab die Briefe wie versprochen im Wiki verlinkt. Da ich keine
passende Seite gefunden habe, hab ich hier
http://wiki.freifunk.net/Beispielanschreiben eine neue in der Kategory
FAQ angelegt. Keine Ahnung wo man das noch verlinken könnte.
Sieht doch ganz gut aus. Danke!
Post by wg1337
Uuuund: Heute ist unsere kleine süße NanoStation loco M5 angekommen, mit
der wir vom Balkon aus schonmal testen könnten \o/
Im Wiki steht ja, dass da kein OpenWrt drauf geht und ich habe nur die
Screenshots auf dieser Seite
http://wiki.freifunk.net/Berlin:Standorte:Bezirksamt_Kreuzberg gefunden.
Gibt es noch irgendwo eine Anleitung, die ich übersehen habe? Wenn nicht
könnten wir versuchen uns an den Screenshots langzuhangeln. Gibt es
dabei was zu beachten bzw. was sollte man unbedingt vorher gelesen haben?
Ihr könnt die Nanostation erst mal mit der originalen Firmware testen.
Dazu einfach auf dem Router einloggen und im Wireless-Bereich nach der
SCAN-Funktion suchen und Router Richtung Rathaus halten.
Wenn ihr guten Empfang habt, könnt ihr den Router entweder weiter mit
der Original-Firmware und einem zweiten OpenWrt-Router betreiben oder
OpenWrT auf der Nanostation installieren.
In beiden Fällen müsst ihr den Router als Client/Station mit einem
Master auf dem Rathaus verbinden. Einfach den Master wählen, der den
besten Empfang verspricht. Sicherstellen, dass der Client auch Daten
senden und empfangen kann. Kann er das nicht, ist meistens die
WDS-Einstellung Schuld.
Wenn ihr den Router mit der originalen Firmware nutzt, den Bridge-Mode
einschalten und WDS ausschalten (ist das richtig?). Der Bridge-Mode
leitet die Daten vom WLAN über das LAN zu einem zweiten Router. Auf dem
zweiten Router muss dann OLSR auf dem Netzwerk-Port konfiguriert sein.
Der zweite Router übernimmt dann das eigentliche Routing.
Wenn ihr OpenWrt nutzt, dann könnt ihr die Nanostation ganz normal mit
dem Freifunk-Assistenten einrichten. Danach müsst ihr das WLAN im
Terminal bzw. in der Konfiguration als Station/Client konfigurieren
(Mode [1]) und den richtigen Channel und SSID wählen.
[1] http://wiki.openwrt.org/doc/uci/wireless
Könnt ihr damit was anfangen?
Viel Erfolg!
LG Philipp
Post by wg1337
Schöne Grüße
maria
Post by wg1337
Vielen Dank für die Anworten. Hier ist der Text den wir schicken
würden: http://pad.spline.de/K5IAQVNYFT
Über Anmerkungen würen wir uns freuen!
Schöne Grüße
maria
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname : signature.asc
Dateityp : application/pgp-signature
Dateigröße : 901 bytes
Beschreibung: OpenPGP digital signature
URL : <http://lists.berlin.freifunk.net/cgi-bin/mailman/private/berlin/attachments/20140502/39b41c05/attachment.pgp>
wg1337
2014-05-02 20:11:40 UTC
Permalink
Post by Philipp Borgers
http://wiki.freifunk.net/Berlin:Standorte:Rathaus_Neukoelln#IPs
Wenn euer Setup erfolgreich mit dem Rathaus verbunden ist, solltet ihr
den Core-Router unter 104.206.3.1 erreichen. Wenn ihr gucken wollt, ob
ihr vom Rathaus weiter kommt, könnt ihr z.B. den Core-Router der
Martin-Luther-Kirche pingen: 104.206.1.14
Wir erreichen vom Router im Wohnzimmer per ping 104.206.3.26,
104.206.3.3 und 104.206.3.1 die werden auch im Webinterface angezeigt.
Die Kirche geht auch
traceroute to 104.206.1.14 (104.206.1.14), 30 hops max, 38 byte packets
1 mid13.rhnk-core.olsr (104.206.3.26) 1.168 ms 1.280 ms 0.932 ms
2 mid2.f2a-core-rt.olsr (104.131.7.28) 32.503 ms 110.626 ms 95.515 ms
3 mid1.martin-luther-core.olsr (104.206.1.14) 1842.886 ms 2764.946
ms 256.882 ms

Von der Nanostation aus geht das nicht.
Post by Philipp Borgers
Die 104.205.0.77 ist die IP des Internet-Routers auf dem neuen Interface?
Das ist der Router im Wohnzimmer. Die Nanostation hat 104.205.0.78
Post by Philipp Borgers
Was habt ihr jetzt auf der Nanostation installiert? Freifunk-Firmware
oder Ubiquiti-Firmware? Ideal wäre, wenn ihr nochmal beschreibt, was ihr
wo konfiguriert habt. Konfiguration kopieren geht auch.
Wir haben folgendes gemacht. Auf der Nanostation läuft noch die
Herstellersoftware. Da haben wir wie beschrieben gescannt und dann einen
Accesspoint ausgewählt. Dann haben wir noch der Nanostation die IP
104.205.0.78, Netspask 255.255.255.252 und Gateway 104.205.0.77 verpasst.
Auf dem Router im Wohnzimmer haben wir den Switch umkonfiguriert und
noch ein Interface rhnk angelegt:

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '0'
option ports '0t 2 3 4'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 1'

config interface 'dhcp'
option ifname 'eth0.0'
option type 'bridge'
option proto 'static'
option ipaddr '104.205.0.49'
option netmask '255.255.255.240'
option ip6assign '64'

config interface 'rhnk'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '104.205.0.77'
option netmask '255.255.255.252'
Post by Philipp Borgers
Auf dem Internet-Router müsst ihr sicherstellen, dass der Port an dem
die Nanostation hängt auch in der Firewall (/etc/config/firewall) in der
richtigen Zone (freifunk) ist. Man kann eine Liste von Interfaces
angeben. Das sollte verhindern, dass Daten einfach so ins Internet
geleitet werden.
in /etc/config/firewall haben wir rhnk dazugeschrieben:

config zone 'zone_freifunk'
option masq '1'
option input 'ACCEPT'
option forward 'REJECT'
option name 'freifunk'
option output 'ACCEPT'
option network 'tunl0 wireless0 wireless1 dhcp ffvpn rhnk'
list masq_src '255.255.255.255/32'
list masq_src '192.168.42.1/24'
Post by Philipp Borgers
Der Internet-Router muss auf dem Interface zur Nanostation OLSR sprechen
um mit dem ganzen Netz zu sprechen. Das könnt ihr in /etc/config/olsrd
einstellen.
Da haben wir nichts gemacht. Aber da steht das rhnk steht schon drin,
muss das so?

config LoadPlugin
option library 'olsrd_arprefresh.so.0.1'

config LoadPlugin
option library 'olsrd_txtinfo.so.0.1'
option accept '0.0.0.0'

config LoadPlugin
option library 'olsrd_jsoninfo.so.0.0'
option ignore '0'
option accept '0.0.0.0'

config olsrd
option RtTableDefault '112'
option RtTableTunnel '113'
option RtTable '111'
option IpVersion '6and4'
option AllowNoInt 'yes'
option NatThreshold '0.75'
option LinkQualityAlgorithm 'etx_ff'
option FIBMetric 'flat'
option TcRedundancy '2'
option SmartGateway 'yes'
option Pollrate '0.025'
option LinkQualityLevel '2'
option OlsrPort '698'
option SmartGatewayUplink 'both'
option Willingness '3'
option SmartGatewaySpeed '20000 100000'

config InterfaceDefaults
option MidValidityTime '500.0'
option TcInterval '2.0'
option HnaValidityTime '125.0'
option HelloValidityTime '125.0'
option TcValidityTime '500.0'
option Ip4Broadcast '255.255.255.255'
option MidInterval '25.0'
option HelloInterval '3.0'
option HnaInterval '10.0'
option Mode 'mesh'

config LoadPlugin
option UdpDestPort '224.0.0.251 5353'
option P2pdTtl '10'
option library 'olsrd_p2pd.so.0.1.0'
option ignore '0'
list NonOlsrIf 'wireless0dhcp'

config Interface
option ignore '0'
option interface 'wireless0'
option Mode 'mesh'

config Hna4
option netmask '255.255.255.240'
option netaddr '104.205.0.48'

config LoadPlugin
option interval '30'
option file '/var/run/olsrd.watchdog'
option library 'olsrd_watchdog.so.0.1'

config LoadPlugin
option lon '13.445185566405606'
option services_file '/var/etc/services.olsr'
option library 'olsrd_nameservice.so.0.3'
option suffix '.olsr'
option latlon_file '/var/run/latlon.js'
option lat '52.471192481033456'
option hosts_file '/tmp/hosts/olsr'

config Hna6
option prefix '48'
option netaddr 'FD35:7B85:10DF:0:0:0:0:0'

config LoadPlugin
option library 'olsrd_dyn_gw_plain.so.0.4'

config Interface
option ignore '0'
option interface 'wireless1'
option Mode 'mesh'

config Interface
option ignore '0'
option interface 'rhnk'
option Mode 'mesh'

Folgendes lässt sich noch beobachten:

traceroute vom Router im Wohnzimmer zu 8.8.8.8 führt am vpn vorbei
direkt über unser DSL. traceroute von der Nanostation aus führt über den
Router im Wohnzimmer auch am vpn vorbei über unser DSL. traceroute von
meinem Notebook das im freifunk hängt, ist wie gewünscht
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 104.205.0.49 (104.205.0.49) 1.982 ms 2.660 ms 4.786 ms
2 172.31.240.1 (172.31.240.1) 21.938 ms 22.710 ms 23.505 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 24.277 ms 25.278 ms 26.068 ms
4 vlan935.sepia.in-berlin.de (217.197.91.131) 28.462 ms 29.270 ms
30.233 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 33.174 ms 34.874 ms
37.646 ms
6 google.ber.ecix.net (194.9.117.34) 37.644 ms 20.613 ms 20.977 ms
7 209.85.249.182 (209.85.249.182) 24.227 ms 209.85.249.184
(209.85.249.184) 25.177 ms 26.320 ms
8 66.249.95.175 (66.249.95.175) 27.107 ms 27.103 ms 29.553 ms
9 216.239.48.53 (216.239.48.53) 29.522 ms 64.233.174.55
(64.233.174.55) 29.533 ms 64.233.174.53 (64.233.174.53) 29.512

Wir haben noch einen zweiten Router in der Küche stehen (104.205.1.193),
der meshed mit dem im Wohnzimmer und von dem aus klappt das mit dem VPN:
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
1 mid2.wg1337.olsr (104.205.0.14) 1.229 ms 1.190 ms 1.093 ms
2 172.31.240.1 (172.31.240.1) 23.554 ms 23.637 ms 19.943 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 26.492 ms 21.515 ms 20.780 ms
4 vlan935.sepia.in-berlin.de (217.197.91.131) 19.102 ms 21.691 ms
18.107 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 18.799 ms 23.875 ms
24.018 ms
6 google.ber.ecix.net (194.9.117.34) 19.617 ms 23.474 ms 21.955 ms
7 209.85.249.184 (209.85.249.184) 20.404 ms 30.739 ms 20.956 ms
8 64.233.175.185 (64.233.175.185) 26.715 ms 64.233.175.187
(64.233.175.187) 22.497 ms 66.249.95.175 (66.249.95.175) 22.618 ms
9 64.233.174.55 (64.233.174.55) 21.070 ms 20.826 ms 64.233.174.53
(64.233.174.53) 28.060 ms
10 * * *
11 google-public-dns-a.google.com (8.8.8.8) 24.675 ms 41.397 ms 24.315 ms


Nach unserer Firewall, die wir in unserem internen Netz betreiben gibt
es super viele Verbindungen (1297) vom Wohnzimmerrouter, die es wohl
nicht gäbe, wenn alles durchs VPN ginge. Das ist irgendwie schräg.
Die Routen auf dem Wohnzimerrouter sind auch schräg:
root at wg1337:~# netstat -r
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt
Iface
default 192.168.42.1 0.0.0.0 UG 0 0 0
eth1
104.0.0.0 * 255.0.0.0 U 0 0 0
wlan0
104.0.0.0 * 255.0.0.0 U 0 0 0
wlan1
104.205.0.48 * 255.255.255.240 U 0 0 0
br-dhcp
104.205.0.76 * 255.255.255.252 U 0 0 0
eth0.1
172.31.240.0 * 255.255.240.0 U 0 0 0
ffvpn
192.168.42.0 * 255.255.255.0 U 0 0 0
eth1

Wo ist denn z.B. konfiguriert, dass Packete an 172.31.240.0 gehen? Und
die Routingtabelle auf dem Küchenrouter sind ganz anders aus, da sind
865 Freifunkrouten drin.
Post by Philipp Borgers
booo at jabber.spline.de
LG Philipp
Dem Binco gehen die Ideen aus^^ Ich denke die Firewall spinnt und das
Policyrouting kapieren wir noch nich.. Was meint ihr?


Schöne Grüße
maria
Post by Philipp Borgers
Post by wg1337
Danke für die Hinweise, ich denke wir haben gestern was hinbekommen. Wir
haben uns erstmal mit freifunk-bbb-rhnk-ssw verbunden
(freifunk-bbb-rhnk-oso würde auch gehen und btw wir sehen auch
freifunk-martin-luther-sw) Wir haben der Nanostation die IP 104.205.0.78
gegeben und mit unserem Freifunkrouter im Wohnzimmer verbunden (auf dem
haben wir einen der Switchports umkonfiguriert und noch ein Interface
für ein Netzwerk mit der Nanostation angelegt).
Wie testen wir jetzt am besten ob da auch was vom Rathaus ankommt und
wieder zurück geht und ob unser Internet richtig benutzt wird? Die
Graphen auf der Nanostation und auf dem Freifunkrouter gehen schon
Wenn ich mit meinem Laptop in unserem Freifunk bin und ein traceroute
mache, gehen die Packete über
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 104.205.0.49 (104.205.0.49) 2.566 ms 3.245 ms 5.125 ms
2 172.31.240.1 (172.31.240.1) 22.555 ms 24.734 ms 26.192 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 27.001 ms 27.854 ms 28.656 ms
4 vlan935.sepia.in-berlin.de (217.197.91.131) 29.441 ms 30.241 ms
31.141 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 32.333 ms 34.094 ms
35.119 ms
6 google.ber.ecix.net (194.9.117.34) 36.070 ms 24.303 ms 21.882 ms
7 209.85.249.184 (209.85.249.184) 24.071 ms 24.875 ms 29.587 ms
8 66.249.95.143 (66.249.95.143) 29.594 ms 66.249.95.175
(66.249.95.175) 32.655 ms 64.233.175.187 (64.233.175.187) 32.617 ms
9 216.239.48.53 (216.239.48.53) 32.622 ms 64.233.174.55
(64.233.174.55) 33.445 ms 216.239.48.53 (216.239.48.53) 32.596 ms
10 * * *
11 google-public-dns-a.google.com (8.8.8.8) 21.893 ms 22.736 ms 23.642 ms
1 104.205.0.77 0.505 ms · 0.379 ms · 0.322 ms
2 217.0.119... 16.007 ms · 48.543 ms · 15.955 ms
3 217.0.76... 54.295 ms · 18.113 ms · 57.684 ms
4 62.154.47.69 155.259 ms · 16.187 ms · 60.107 ms
5 194.25.211.26 18.833 ms · 62.464 ms · 16.542 ms
6 209.85.249.182 36.444 ms · 72.146 ms · 16.399 ms
7 64.233.175.187 17.644 ms · 16.884 ms · 54.441 ms
8 64.233.174.53 17.277 ms · 93.991 ms · 17.091 ms
9 * · * · *
10 8.8.8.8 16.930 ms · 53.368 ms · 16.634 ms
Das sieht irgendwie falsch aus. Die Packete von der Nanostation müssen
doch auch durch das VPN, oder?
Schöne Grüße
maria
Sven-Ola Tuecke
2014-05-02 21:46:04 UTC
Permalink
N'abend,

hab jetzt nicht alles gelesen. Aber "netstat -r" zeigt nicht alles an, nur die "main" Table. Ruf mal "ip" auf, etwa so:

ip route show table all # zeigt alles
ip r ls table xxx # einzelne Tabelle, Kurznotation
ip r ls scope link # Maintable, nur statische Routen
ip r get 1.2.3.4 # wo gehts hier nach 1.2.3.4?
ip rule show # Regelliste, wann welche tabelle
ip l # Interfaceconfig zeigen
ip -4 a # IPv4 Config zeigen

HTH // Sven-Ola
Post by wg1337
Post by Philipp Borgers
http://wiki.freifunk.net/Berlin:Standorte:Rathaus_Neukoelln#IPs
Wenn euer Setup erfolgreich mit dem Rathaus verbunden ist, solltet
ihr
Post by Philipp Borgers
den Core-Router unter 104.206.3.1 erreichen. Wenn ihr gucken wollt,
ob
Post by Philipp Borgers
ihr vom Rathaus weiter kommt, könnt ihr z.B. den Core-Router der
Martin-Luther-Kirche pingen: 104.206.1.14
Wir erreichen vom Router im Wohnzimmer per ping 104.206.3.26,
104.206.3.3 und 104.206.3.1 die werden auch im Webinterface angezeigt.
Die Kirche geht auch
traceroute to 104.206.1.14 (104.206.1.14), 30 hops max, 38 byte packets
1 mid13.rhnk-core.olsr (104.206.3.26) 1.168 ms 1.280 ms 0.932 ms
2 mid2.f2a-core-rt.olsr (104.131.7.28) 32.503 ms 110.626 ms 95.515 ms
3 mid1.martin-luther-core.olsr (104.206.1.14) 1842.886 ms 2764.946
ms 256.882 ms
Von der Nanostation aus geht das nicht.
Post by Philipp Borgers
Die 104.205.0.77 ist die IP des Internet-Routers auf dem neuen
Interface?
Das ist der Router im Wohnzimmer. Die Nanostation hat 104.205.0.78
Post by Philipp Borgers
Was habt ihr jetzt auf der Nanostation installiert? Freifunk-Firmware
oder Ubiquiti-Firmware? Ideal wäre, wenn ihr nochmal beschreibt, was
ihr
Post by Philipp Borgers
wo konfiguriert habt. Konfiguration kopieren geht auch.
Wir haben folgendes gemacht. Auf der Nanostation läuft noch die
Herstellersoftware. Da haben wir wie beschrieben gescannt und dann einen
Accesspoint ausgewählt. Dann haben wir noch der Nanostation die IP
104.205.0.78, Netspask 255.255.255.252 und Gateway 104.205.0.77
verpasst.
Auf dem Router im Wohnzimmer haben wir den Switch umkonfiguriert und
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '0'
option ports '0t 2 3 4'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 1'
config interface 'dhcp'
option ifname 'eth0.0'
option type 'bridge'
option proto 'static'
option ipaddr '104.205.0.49'
option netmask '255.255.255.240'
option ip6assign '64'
config interface 'rhnk'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '104.205.0.77'
option netmask '255.255.255.252'
Post by Philipp Borgers
Auf dem Internet-Router müsst ihr sicherstellen, dass der Port an dem
die Nanostation hängt auch in der Firewall (/etc/config/firewall) in
der
Post by Philipp Borgers
richtigen Zone (freifunk) ist. Man kann eine Liste von Interfaces
angeben. Das sollte verhindern, dass Daten einfach so ins Internet
geleitet werden.
config zone 'zone_freifunk'
option masq '1'
option input 'ACCEPT'
option forward 'REJECT'
option name 'freifunk'
option output 'ACCEPT'
option network 'tunl0 wireless0 wireless1 dhcp ffvpn rhnk'
list masq_src '255.255.255.255/32'
list masq_src '192.168.42.1/24'
Post by Philipp Borgers
Der Internet-Router muss auf dem Interface zur Nanostation OLSR
sprechen
Post by Philipp Borgers
um mit dem ganzen Netz zu sprechen. Das könnt ihr in
/etc/config/olsrd
Post by Philipp Borgers
einstellen.
Da haben wir nichts gemacht. Aber da steht das rhnk steht schon drin,
muss das so?
config LoadPlugin
option library 'olsrd_arprefresh.so.0.1'
config LoadPlugin
option library 'olsrd_txtinfo.so.0.1'
option accept '0.0.0.0'
config LoadPlugin
option library 'olsrd_jsoninfo.so.0.0'
option ignore '0'
option accept '0.0.0.0'
config olsrd
option RtTableDefault '112'
option RtTableTunnel '113'
option RtTable '111'
option IpVersion '6and4'
option AllowNoInt 'yes'
option NatThreshold '0.75'
option LinkQualityAlgorithm 'etx_ff'
option FIBMetric 'flat'
option TcRedundancy '2'
option SmartGateway 'yes'
option Pollrate '0.025'
option LinkQualityLevel '2'
option OlsrPort '698'
option SmartGatewayUplink 'both'
option Willingness '3'
option SmartGatewaySpeed '20000 100000'
config InterfaceDefaults
option MidValidityTime '500.0'
option TcInterval '2.0'
option HnaValidityTime '125.0'
option HelloValidityTime '125.0'
option TcValidityTime '500.0'
option Ip4Broadcast '255.255.255.255'
option MidInterval '25.0'
option HelloInterval '3.0'
option HnaInterval '10.0'
option Mode 'mesh'
config LoadPlugin
option UdpDestPort '224.0.0.251 5353'
option P2pdTtl '10'
option library 'olsrd_p2pd.so.0.1.0'
option ignore '0'
list NonOlsrIf 'wireless0dhcp'
config Interface
option ignore '0'
option interface 'wireless0'
option Mode 'mesh'
config Hna4
option netmask '255.255.255.240'
option netaddr '104.205.0.48'
config LoadPlugin
option interval '30'
option file '/var/run/olsrd.watchdog'
option library 'olsrd_watchdog.so.0.1'
config LoadPlugin
option lon '13.445185566405606'
option services_file '/var/etc/services.olsr'
option library 'olsrd_nameservice.so.0.3'
option suffix '.olsr'
option latlon_file '/var/run/latlon.js'
option lat '52.471192481033456'
option hosts_file '/tmp/hosts/olsr'
config Hna6
option prefix '48'
option netaddr 'FD35:7B85:10DF:0:0:0:0:0'
config LoadPlugin
option library 'olsrd_dyn_gw_plain.so.0.4'
config Interface
option ignore '0'
option interface 'wireless1'
option Mode 'mesh'
config Interface
option ignore '0'
option interface 'rhnk'
option Mode 'mesh'
traceroute vom Router im Wohnzimmer zu 8.8.8.8 führt am vpn vorbei
direkt über unser DSL. traceroute von der Nanostation aus führt über den
Router im Wohnzimmer auch am vpn vorbei über unser DSL. traceroute von
meinem Notebook das im freifunk hängt, ist wie gewünscht
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 104.205.0.49 (104.205.0.49) 1.982 ms 2.660 ms 4.786 ms
2 172.31.240.1 (172.31.240.1) 21.938 ms 22.710 ms 23.505 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 24.277 ms 25.278 ms 26.068 ms
4 vlan935.sepia.in-berlin.de (217.197.91.131) 28.462 ms 29.270 ms
30.233 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 33.174 ms 34.874 ms
37.646 ms
6 google.ber.ecix.net (194.9.117.34) 37.644 ms 20.613 ms 20.977 ms
7 209.85.249.182 (209.85.249.182) 24.227 ms 209.85.249.184
(209.85.249.184) 25.177 ms 26.320 ms
8 66.249.95.175 (66.249.95.175) 27.107 ms 27.103 ms 29.553 ms
9 216.239.48.53 (216.239.48.53) 29.522 ms 64.233.174.55
(64.233.174.55) 29.533 ms 64.233.174.53 (64.233.174.53) 29.512
Wir haben noch einen zweiten Router in der Küche stehen
(104.205.1.193),
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
1 mid2.wg1337.olsr (104.205.0.14) 1.229 ms 1.190 ms 1.093 ms
2 172.31.240.1 (172.31.240.1) 23.554 ms 23.637 ms 19.943 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 26.492 ms 21.515 ms 20.780 ms
4 vlan935.sepia.in-berlin.de (217.197.91.131) 19.102 ms 21.691 ms
18.107 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 18.799 ms 23.875 ms
24.018 ms
6 google.ber.ecix.net (194.9.117.34) 19.617 ms 23.474 ms 21.955 ms
7 209.85.249.184 (209.85.249.184) 20.404 ms 30.739 ms 20.956 ms
8 64.233.175.185 (64.233.175.185) 26.715 ms 64.233.175.187
(64.233.175.187) 22.497 ms 66.249.95.175 (66.249.95.175) 22.618 ms
9 64.233.174.55 (64.233.174.55) 21.070 ms 20.826 ms 64.233.174.53
(64.233.174.53) 28.060 ms
10 * * *
11 google-public-dns-a.google.com (8.8.8.8) 24.675 ms 41.397 ms 24.315 ms
Nach unserer Firewall, die wir in unserem internen Netz betreiben gibt
es super viele Verbindungen (1297) vom Wohnzimmerrouter, die es wohl
nicht gäbe, wenn alles durchs VPN ginge. Das ist irgendwie schräg.
root at wg1337:~# netstat -r
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt
Iface
default 192.168.42.1 0.0.0.0 UG 0 0
0
eth1
104.0.0.0 * 255.0.0.0 U 0 0
0
wlan0
104.0.0.0 * 255.0.0.0 U 0 0
0
wlan1
104.205.0.48 * 255.255.255.240 U 0 0
0
br-dhcp
104.205.0.76 * 255.255.255.252 U 0 0
0
eth0.1
172.31.240.0 * 255.255.240.0 U 0 0
0
ffvpn
192.168.42.0 * 255.255.255.0 U 0 0
0
eth1
Wo ist denn z.B. konfiguriert, dass Packete an 172.31.240.0 gehen? Und
die Routingtabelle auf dem Küchenrouter sind ganz anders aus, da sind
865 Freifunkrouten drin.
Post by Philipp Borgers
booo at jabber.spline.de
LG Philipp
Dem Binco gehen die Ideen aus^^ Ich denke die Firewall spinnt und das
Policyrouting kapieren wir noch nich.. Was meint ihr?
Schöne Grüße
maria
Post by Philipp Borgers
Post by wg1337
Danke für die Hinweise, ich denke wir haben gestern was hinbekommen.
Wir
Post by Philipp Borgers
Post by wg1337
haben uns erstmal mit freifunk-bbb-rhnk-ssw verbunden
(freifunk-bbb-rhnk-oso würde auch gehen und btw wir sehen auch
freifunk-martin-luther-sw) Wir haben der Nanostation die IP
104.205.0.78
Post by Philipp Borgers
Post by wg1337
gegeben und mit unserem Freifunkrouter im Wohnzimmer verbunden (auf
dem
Post by Philipp Borgers
Post by wg1337
haben wir einen der Switchports umkonfiguriert und noch ein
Interface
Post by Philipp Borgers
Post by wg1337
für ein Netzwerk mit der Nanostation angelegt).
Wie testen wir jetzt am besten ob da auch was vom Rathaus ankommt
und
Post by Philipp Borgers
Post by wg1337
wieder zurück geht und ob unser Internet richtig benutzt wird? Die
Graphen auf der Nanostation und auf dem Freifunkrouter gehen schon
Wenn ich mit meinem Laptop in unserem Freifunk bin und ein
traceroute
Post by Philipp Borgers
Post by wg1337
mache, gehen die Packete über
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 104.205.0.49 (104.205.0.49) 2.566 ms 3.245 ms 5.125 ms
2 172.31.240.1 (172.31.240.1) 22.555 ms 24.734 ms 26.192 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 27.001 ms 27.854 ms
28.656 ms
Post by Philipp Borgers
Post by wg1337
4 vlan935.sepia.in-berlin.de (217.197.91.131) 29.441 ms 30.241
ms
Post by Philipp Borgers
Post by wg1337
31.141 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 32.333 ms 34.094
ms
Post by Philipp Borgers
Post by wg1337
35.119 ms
6 google.ber.ecix.net (194.9.117.34) 36.070 ms 24.303 ms
21.882 ms
Post by Philipp Borgers
Post by wg1337
7 209.85.249.184 (209.85.249.184) 24.071 ms 24.875 ms 29.587
ms
Post by Philipp Borgers
Post by wg1337
8 66.249.95.143 (66.249.95.143) 29.594 ms 66.249.95.175
(66.249.95.175) 32.655 ms 64.233.175.187 (64.233.175.187) 32.617
ms
Post by Philipp Borgers
Post by wg1337
9 216.239.48.53 (216.239.48.53) 32.622 ms 64.233.174.55
(64.233.174.55) 33.445 ms 216.239.48.53 (216.239.48.53) 32.596 ms
10 * * *
11 google-public-dns-a.google.com (8.8.8.8) 21.893 ms 22.736 ms 23.642 ms
1 104.205.0.77 0.505 ms · 0.379 ms · 0.322 ms
2 217.0.119... 16.007 ms · 48.543 ms · 15.955 ms
3 217.0.76... 54.295 ms · 18.113 ms · 57.684 ms
4 62.154.47.69 155.259 ms · 16.187 ms · 60.107 ms
5 194.25.211.26 18.833 ms · 62.464 ms · 16.542 ms
6 209.85.249.182 36.444 ms · 72.146 ms · 16.399 ms
7 64.233.175.187 17.644 ms · 16.884 ms · 54.441 ms
8 64.233.174.53 17.277 ms · 93.991 ms · 17.091 ms
9 * · * · *
10 8.8.8.8 16.930 ms · 53.368 ms · 16.634 ms
Das sieht irgendwie falsch aus. Die Packete von der Nanostation
müssen
Post by Philipp Borgers
Post by wg1337
doch auch durch das VPN, oder?
Schöne Grüße
maria
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
--
Diese Nachricht wurde von meinem Android-Mobiltelefon mit K-9 Mail gesendet.
-------------- nächster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.berlin.freifunk.net/cgi-bin/mailman/private/berlin/attachments/20140502/c8924044/attachment.html>
wg1337
2014-05-03 22:31:37 UTC
Permalink
So, ich denke unser Problem ist gelöst.
Das Problem war, dass zwei Firewallregeln nicht gesetz wurden:
20001: from all iif eth0.1 unreachable
20001 iif eth0.1 lookup olsr-default
haben gefehlt.
Nachdem die dazugetan wurden, ging der ganze Traffic schön übers VPN.
Nur leider hat der Router das nach nem Neustart immer wieder vergessen :/
Binco und ich haben dann beschlossen hier noch mal alles umzubauen, weil
wir die Firewall auf dem Router nicht verstehen, mit unserer besser
klarkommen und weil wir noch ein Gastnetzwerk hatten das wir jetzt
rausegeschmissen haben.
Jetzt läuft es folgendermaßen:
VPN läuft auf unserer internen Firewall (104.205.0.73) und es gibt ein
vlan, in dem die ganzen Freifunggeräte mit Freifunk-IPs hängen. Wir
haben auch unsere ganzen IPs mal aufgeräumt, umsortiert und ordentlich
in die Tabelle http://ip.berlin.freifunk.net/ip_uebersicht.html
eingetragen. Die Nanostation (|104.205.0.75|) hängt über den
Wohnzimmerouterswitch (|104.205.0.74|) auch mit im vlan. Der Küchrouter
mashed mit dem Wohnzimmerrouter. Alle Geräte und Clients gehen über vpn.
Und über das Rathaus läuft auch alles:
von meinem Laptop aus
traceroute to 104.206.1.14 (104.206.1.14), 30 hops max, 60 byte packets
1 104.205.1.193 (104.205.1.193) 1.192 ms 1.200 ms 1.296 ms
2 wg1337-west.olsr (104.205.0.12) 7.545 ms 12.084 ms 12.194 ms
3 mid9.rhnk-core.olsr (104.206.3.26) 12.844 ms 14.088 ms 17.662 ms
4 mid2.f2a-core-rt.olsr (104.131.7.28) 19.021 ms 20.467 ms 20.513 ms
5 mid1.martin-luther-core.olsr (104.206.1.14) 23.019 ms 23.904 ms 26.084 ms

Ich denk das kann erstmal so bleiben, oder? Was wir jetzt gerne noch
wissen würden ist ob, denn vom Rathaus aus, die Leute auch über uns das
Internet finden oder nicht.

schöne grüße
maria
Post by Sven-Ola Tuecke
N'abend,
ip route show table all # zeigt alles
ip r ls table xxx # einzelne Tabelle, Kurznotation
ip r ls scope link # Maintable, nur statische Routen
ip r get 1.2.3.4 # wo gehts hier nach 1.2.3.4?
ip rule show # Regelliste, wann welche tabelle
ip l # Interfaceconfig zeigen
ip -4 a # IPv4 Config zeigen
HTH // Sven-Ola
Post by wg1337
Post by Philipp Borgers
http://wiki.freifunk.net/Berlin:Standorte:Rathaus_Neukoelln#IPs
Wenn euer Setup erfolgreich mit dem Rathaus verbunden ist, solltet
ihr
Post by Philipp Borgers
den Core-Router unter 104.206.3.1 erreichen. Wenn ihr gucken wollt,
ob
Post by Philipp Borgers
ihr vom Rathaus weiter kommt, könnt ihr z.B. den Core-Router der
Martin-Luther-Kirche pingen: 104.206.1.14
Wir erreichen vom Router im Wohnzimmer per ping 104.206.3.26,
104.206.3.3 und 104.206.3.1 die werden auch im Webinterface angezeigt.
Die Kirche geht auch
traceroute to 104.206.1.14 (104.206.1.14), 30 hops max, 38 byte packets
1 mid13.rhnk-core.olsr (104.206.3.26) 1.168 ms 1.280 ms 0.932 ms
2 mid2.f2a-core-rt.olsr (104.131.7.28) 32.503 ms 110.626 ms 95.515 ms
3 mid1.martin-luther-core.olsr (104.206.1.14) 1842.886 ms 2764.946
ms 256.882 ms
Von der Nanostation aus geht das nicht.
Post by Philipp Borgers
Die 104.205.0.77 ist die IP des Internet-Routers auf dem neuen
Interface?
Das ist der Router im Wohnzimmer. Die Nanostation hat 104.205.0.78
Post by Philipp Borgers
Was habt ihr jetzt auf der Nanostation installiert? Freifunk-Firmware
oder Ubiquiti-Firmware? Ideal wäre, wenn ihr nochmal beschreibt, was
ihr
Post by Philipp Borgers
wo konfiguriert habt. Konfiguration kopieren geht auch.
Wir haben folgendes gemacht. Auf der Nanostation läuft noch die
Herstellersoftware. Da haben wir wie beschrieben gescannt und dann einen
Accesspoint ausgewählt. Dann haben wir noch der Nanostation die IP
104.205.0.78, Netspask 255.255.255.252 und Gateway 104.205.0.77 verpasst.
Auf dem Router im Wohnzimmer haben wir den Switch umkonfiguriert und
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '0'
option ports '0t 2 3 4'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 1'
config interface 'dhcp'
option ifname 'eth0.0'
option type 'bridge'
option proto 'static'
option ipaddr '104.205.0.49'
option netmask '255.255.255.240'
option ip6assign '64'
config interface 'rhnk'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '104.205.0.77'
option netmask '255.255.255.252'
Post by Philipp Borgers
Auf dem Internet-Router müsst ihr sicherstellen, dass der Port an dem
die Nanostation hängt auch in der Firewall (/etc/config/firewall) in
der
Post by Philipp Borgers
richtigen Zone (freifunk) ist. Man kann eine Liste von Interfaces
angeben. Das sollte verhindern, dass Daten einfach so ins Internet
geleitet werden.
config zone 'zone_freifunk'
option masq '1'
option input 'ACCEPT'
option forward 'REJECT'
option name 'freifunk'
option output 'ACCEPT'
option network 'tunl0 wireless0 wireless1 dhcp ffvpn rhnk'
list masq_src '255.255.255.255/32'
list masq_src '192.168.42.1/24'
Post by Philipp Borgers
Der Internet-Router muss auf dem Interface zur Nanostation OLSR
sprechen
Post by Philipp Borgers
um mit dem ganzen Netz zu sprechen. Das könnt ihr in
/etc/config/olsrd
Post by Philipp Borgers
einstellen.
Da haben wir nichts gemacht. Aber da steht das rhnk steht schon drin,
muss das so?
config LoadPlugin
option library 'olsrd_arprefresh.so.0.1'
config LoadPlugin
option library 'olsrd_txtinfo.so.0.1'
option accept '0.0.0.0'
config LoadPlugin
option library 'olsrd_jsoninfo.so.0.0'
option ignore '0'
option accept '0.0.0.0'
config olsrd
option RtTableDefault '112'
option RtTableTunnel '113'
option RtTable '111'
option IpVersion '6and4'
option AllowNoInt 'yes'
option NatThreshold '0.75'
option LinkQualityAlgorithm 'etx_ff'
option FIBMetric 'flat'
option TcRedundancy '2'
option SmartGateway 'yes'
option Pollrate '0.025'
option LinkQualityLevel '2'
option OlsrPort '698'
option SmartGatewayUplink 'both'
option Willingness '3'
option SmartGatewaySpeed '20000 100000'
config InterfaceDefaults
option MidValidityTime '500.0'
option TcInterval '2.0'
option HnaValidityTime '125.0'
option HelloValidityTime '125.0'
option TcValidityTime '500.0'
option Ip4Broadcast '255.255.255.255'
option MidInterval '25.0'
option HelloInterval '3.0'
option HnaInterval '10.0'
option Mode 'mesh'
config LoadPlugin
option UdpDestPort '224.0.0.251 5353'
option P2pdTtl '10'
option library 'olsrd_p2pd.so.0.1.0'
option ignore '0'
list NonOlsrIf 'wireless0dhcp'
config Interface
option ignore '0'
option interface 'wireless0'
option Mode 'mesh'
config Hna4
option netmask '255.255.255.240'
option netaddr '104.205.0.48'
config LoadPlugin
option interval '30'
option file '/var/run/olsrd.watchdog'
option library 'olsrd_watchdog.so.0.1'
config LoadPlugin
option lon '13.445185566405606'
option services_file '/var/etc/services.olsr'
option library 'olsrd_nameservice.so.0.3'
option suffix '.olsr'
option latlon_file '/var/run/latlon.js'
option lat '52.471192481033456'
option hosts_file '/tmp/hosts/olsr'
config Hna6
option prefix '48'
option netaddr 'FD35:7B85:10DF:0:0:0:0:0'
config LoadPlugin
option library 'olsrd_dyn_gw_plain.so.0.4'
config Interface
option ignore '0'
option interface 'wireless1'
option Mode 'mesh'
config Interface
option ignore '0'
option interface 'rhnk'
option Mode 'mesh'
traceroute vom Router im Wohnzimmer zu 8.8.8.8 führt am vpn vorbei
direkt über unser DSL. traceroute von der Nanostation aus führt über den
Router im Wohnzimmer auch am vpn vorbei über unser DSL. traceroute von
meinem Notebook das im freifunk hängt, ist wie gewünscht
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 104.205.0.49 (104.205.0.49) 1.982 ms 2.660 ms 4.786 ms
2 172.31.240.1 (172.31.240.1) 21.938 ms 22.710 ms 23.505 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 24.277 ms 25.278 ms 26.068 ms
4 vlan935.sepia.in-berlin.de (217.197.91.131) 28.462 ms 29.270 ms
30.233 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 33.174 ms 34.874 ms
37.646 ms
6 google.ber.ecix.net (194.9.117.34) 37.644 ms 20.613 ms 20.977 ms
7 209.85.249.182 (209.85.249.182) 24.227 ms 209.85.249.184
(209.85.249.184) 25.177 ms 26.320 ms
8 66.249.95.175 (66.249.95.175) 27.107 ms 27.103 ms 29.553 ms
9 216.239.48.53 (216.239.48.53) 29.522 ms 64.233.174.55
(64.233.174.55) 29.533 ms 64.233.174.53 (64.233.174.53) 29.512
Wir haben noch einen zweiten Router in der Küche stehen
(104.205.1.193),
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
1 mid2.wg1337.olsr (104.205.0.14) 1.229 ms 1.190 ms 1.093 ms
2 172.31.240.1 (172.31.240.1) 23.554 ms 23.637 ms 19.943 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 26.492 ms 21.515 ms 20.780 ms
4 vlan935.sepia.in-berlin.de (217.197.91.131) 19.102 ms 21.691 ms
18.107 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 18.799 ms 23.875 ms
24.018 ms
6 google.ber.ecix.net (194.9.117.34) 19.617 ms 23.474 ms 21.955 ms
7 209.85.249.184 (209.85.249.184) 20.404 ms 30.739 ms 20.956 ms
8 64.233.175.185 (64.233.175.185) 26.715 ms 64.233.175.187
(64.233.175.187) 22.497 ms 66.249.95.175 (66.249.95.175) 22.618 ms
9 64.233.174.55 (64.233.174.55) 21.070 ms 20.826 ms 64.233.174.53
(64.233.174.53) 28.060 ms
10 * * *
11 google-public-dns-a.google.com (8.8.8.8) 24.675 ms 41.397 ms 24.315 ms
Nach unserer Firewall, die wir in unserem internen Netz betreiben gibt
es super viele Verbindungen (1297) vom Wohnzimmerrouter, die es wohl
nicht gäbe, wenn alles durchs VPN ginge. Das ist irgendwie schräg.
root at wg1337:~# netstat -r
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt
Iface
default 192.168.42.1 0.0.0.0 UG 0 0
0
eth1
104.0.0.0 * 255.0.0.0 U 0 0
0
wlan0
104.0.0.0 * 255.0.0.0 U 0 0
0
wlan1
104.205.0.48 * 255.255.255.240 U 0 0
0
br-dhcp
104.205.0.76 * 255.255.255.252 U 0 0
0
eth0.1
172.31.240.0 * 255.255.240.0 U 0 0
0
ffvpn
192.168.42.0 * 255.255.255.0 U 0 0
0
eth1
Wo ist denn z.B. konfiguriert, dass Packete an 172.31.240.0 gehen? Und
die Routingtabelle auf dem Küchenrouter sind ganz anders aus, da sind
865 Freifunkrouten drin.
Post by Philipp Borgers
booo at jabber.spline.de
LG Philipp
Dem Binco gehen die Ideen aus^^ Ich denke die Firewall spinnt und das
Policyrouting kapieren wir noch nich.. Was meint ihr?
Schöne Grüße
maria
Post by Philipp Borgers
Post by wg1337
Danke für die Hinweise, ich denke wir haben gestern was hinbekommen.
Wir
Post by Philipp Borgers
Post by wg1337
haben uns erstmal mit freifunk-bbb-rhnk-ssw verbunden
(freifunk-bbb-rhnk-oso würde auch gehen und btw wir sehen auch
freifunk-martin-luther-sw) Wir haben der Nanostation die IP
104.205.0.78
Post by Philipp Borgers
Post by wg1337
gegeben und mit unserem Freifunkrouter im Wohnzimmer verbunden (auf
dem
Post by Philipp Borgers
Post by wg1337
haben wir einen der Switchports umkonfiguriert und noch ein
Interface
Post by Philipp Borgers
Post by wg1337
für ein Netzwerk mit der Nanostation angelegt).
Wie testen wir jetzt am besten ob da auch was vom Rathaus ankommt
und
Post by Philipp Borgers
Post by wg1337
wieder zurück geht und ob unser Internet richtig benutzt wird? Die
Graphen auf der Nanostation und auf dem Freifunkrouter gehen schon
Wenn ich mit meinem Laptop in unserem Freifunk bin und ein
traceroute
Post by Philipp Borgers
Post by wg1337
mache, gehen die Packete über
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 104.205.0.49 (104.205.0.49) 2.566 ms 3.245 ms 5.125 ms
2 172.31.240.1 (172.31.240.1) 22.555 ms 24.734 ms 26.192 ms
3 bgp01.berlin.freifunk.net (77.87.48.1) 27.001 ms 27.854 ms
28.656 ms
Post by Philipp Borgers
Post by wg1337
4 vlan935.sepia.in-berlin.de (217.197.91.131) 29.441 ms 30.241
ms
Post by Philipp Borgers
Post by wg1337
31.141 ms
5 vlan84.octalus.in-berlin.de (192.109.82.65) 32.333 ms 34.094
ms
Post by Philipp Borgers
Post by wg1337
35.119 ms
6 google.ber.ecix.net (194.9.117.34) 36.070 ms 24.303 ms
21.882 ms
Post by Philipp Borgers
Post by wg1337
7 209.85.249.184 (209.85.249.184) 24.071 ms 24.875 ms 29.587
ms
Post by Philipp Borgers
Post by wg1337
8 66.249.95.143 (66.249.95.143) 29.594 ms 66.249.95.175
(66.249.95.175) 32.655 ms 64.233.175.187 (64.233.175.187) 32.617
ms
Post by Philipp Borgers
Post by wg1337
9 216.239.48.53 (216.239.48.53) 32.622 ms 64.233.174.55
(64.233.174.55) 33.445 ms 216.239.48.53 (216.239.48.53) 32.596 ms
10 * * *
11 google-public-dns-a.google.com (8.8.8.8) 21.893 ms 22.736 ms 23.642 ms
1 104.205.0.77 0.505 ms · 0.379 ms · 0.322 ms
2 217.0.119... 16.007 ms · 48.543 ms · 15.955 ms
3 217.0.76... 54.295 ms · 18.113 ms · 57.684 ms
4 62.154.47.69 155.259 ms · 16.187 ms · 60.107 ms
5 194.25.211.26 18.833 ms · 62.464 ms · 16.542 ms
6 209.85.249.182 36.444 ms · 72.146 ms · 16.399 ms
7 64.233.175.187 17.644 ms · 16.884 ms · 54.441 ms
8 64.233.174.53 17.277 ms · 93.991 ms · 17.091 ms
9 * · * · *
10 8.8.8.8 16.930 ms · 53.368 ms · 16.634 ms
Das sieht irgendwie falsch aus. Die Packete von der Nanostation
müssen
Post by Philipp Borgers
Post by wg1337
doch auch durch das VPN, oder?
Schöne Grüße
maria
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
_______________________________________________
Berlin mailing list
Berlin at berlin.freifunk.net
http://lists.berlin.freifunk.net/cgi-bin/mailman/listinfo/berlin
-------------- nächster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.berlin.freifunk.net/cgi-bin/mailman/private/berlin/attachments/20140504/87ec2e69/attachment.html>
Lesen Sie weiter auf narkive:
Loading...